No images uploaded for new articles by the Delcampe API

  • sun10
    10 messages
    Canary Islands
    The images are on my server. Since a few days there are missing pictures in fixed-price articles, uploaded via the API. First only about 10% without pictures, yesterday over 50% without pictures or only one of several pictures. The API worked flawlessly for years with the program.
  • sun10
    10 messages
    Canary Islands
    the day before yesterday again all pictures were there, currently 10% of the pictures are missing again ...
  • @didier
    Administrator
    9 messages
    Belgium
    Dear Sun10,

    There is no know API issues with the images. Can you ask your developer which call is done when image disappear ?
    Don't hesitate to come back to us if you have any additional question.

    Kind Regards.
  • sun10
    10 messages
    Canary Islands
    Hello,

    we are the developers ourselves. The php-code has been working completely correctly for years. Only since about March the pictures do not always work. All images were uploaded correctly on two days. It's completely random. Our server delivers the images quickly and error-free.

    We suspect a timeout problem with too much traffic on the Delcampeserver.

    We send to the API for the images e.g.:

    $data['images'] = array(
    ' Link (http)
    ' Link (http)
    ' Link (http) '
    );

    Function call by $objSoapClient ...

    I will hope, you will find a resolution
  • sun10
    10 messages
    Canary Islands
    Hello,

    yesterday from 14:18, 60 lots are with images uploaded. Did you fix something?
  • @olivier
    Administrator
    237 messages
    Belgium
    Hello,

    yesterday from 14:18, 60 lots are with images uploaded. Did you fix something?
    • Created on 20 Mar 2018 at 07:36
    • #838877
    Hello, no we did not have any problems with downloading images so no correction.
  • cartespostales_de
    8 messages
    Germany
    Hello, no we did not have any problems with downloading images so no correction.
    • Created on 27 Mar 2018 at 08:02
    • #841931
    Same problems here since several weeks. Images are on the server, always available. But a huge uploads by the api does not show images.

    So really, you should not answer there are no problems!
  • sun10
    10 messages
    Canary Islands
    Hello,

    for a few weeks everything has been working perfectly
  • @thomas
    Administrator
    21 messages
    Belgium
    Hello,

    Thanks for your feedback.

    Best regards
  • @olivier
    Administrator
    237 messages
    Belgium
    Same problems here since several weeks. Images are on the server, always available. But a huge uploads by the api does not show images.

    So really, you should not answer there are no problems!
    • Created on 12 Apr 2018 at 05:23
    • #849212
    Hello cartepostales,

    I investigated your case. When downloading the image, the file does not exist.

    I think this is due to our script making mass requests to your server and it doesn't accept as many simultaneous connections.

    You should adapt either the number of API calls or configure your server to accept more connections from our server.

    Best regards,

    Olivier.
  • cartespostales_de
    8 messages
    Germany
    Hello cartepostales,

    I investigated your case. When downloading the image, the file does not exist.

    I think this is due to our script making mass requests to your server and it doesn't accept as many simultaneous connections.

    You should adapt either the number of API calls or configure your server to accept more connections from our server.

    Best regards,

    Olivier.
    • Created on 19 Apr 2018 at 05:24
    • #851672
    "and it doesn't accept as many simultaneous connections"

    it seems, I am not the onliest one, who has the same problem, and it seems, as like as this problem occurs not by changing anything on the server from the sellers but it occurs by changing your upload rules.

    So maybe it would be easier (for all), you will change the upload speed and decrease the mass requests.

    I think, it would be easier for you, to slow down your mass requests (as like as in past) as to explain each seller to raise their server connections or to explain your buyers why you have so much items without pictures on sale.

    Best regards
  • cartespostales_de
    8 messages
    Germany
    "and it doesn't accept as many simultaneous connections"

    it seems, I am not the onliest one, who has the same problem, and it seems, as like as this problem occurs not by changing anything on the server from the sellers but it occurs by changing your upload rules.

    So maybe it would be easier (for all), you will change the upload speed and decrease the mass requests.

    I think, it would be easier for you, to slow down your mass requests (as like as in past) as to explain each seller to raise their server connections or to explain your buyers why you have so much items without pictures on sale.

    Best regards
    • Created on 19 Apr 2018 at 06:06
    • #851708
    3 months later, same problem here.

    Images will not be uploaded for all offers. Server is online, images are available. Please check your upload script.

    Thanks.
    Best regards

Join the collectors community

Register Login